Database maintenance
Incident Report for Ucraft
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 17:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 23, 2022 - 17:09 UTC
This incident affected: Ucraft Builder - Public Mode and Ucraft Builder - Edit Mode.