SSL Certificate issuance problems
Incident Report for Ucraft
Resolved
The incident has been resolved! All the domains are now safe and secure!
Posted 2 months ago. Jul 19, 2019 - 20:41 UTC
Monitoring
We’re currently experiencing some problems with issuing SSL certificates for the custom domains connected to some of our cloud instances on Google.
If you SSL cert has an issue and you still see this, that means your website is on that very instance with the issue.

Please ignore this if your website is up with Ucraft SSL.
Posted 2 months ago. Jul 19, 2019 - 13:15 UTC
This incident affected: Ucraft Builder - Public Mode.